#!perl use strict; use warnings; use Test::More; require_ok( 'Enbld::HTML' ); my $html = Enbld::HTML->new( do { local $/; } ); my $list = $html->parse_version( '', '\d\.\d{2}' ); ok( grep { $_ eq '1.10' } @{ $list} , 'version exists' ); my $empty = Enbld::HTML->new( '' ); my $empty_list = $empty->parse_version( 'archive-1.00.tar.gz archive-1.10.tar.gz